Stylesheet not updating

I added styles to my css file but when I open view source in my browser and click on the link to the stylesheet, I can see that the styles weren’t saved. I stopped the server and cleared the cache with bin/cake cache clear_all and then re-started the server but the stylesheet still doesn’t update.

did you save the changed css file?
did you try “ctrl”+“shift”+“R” in your browser

Thanks, dirk. “ctrl”+“shift”+“R” in my browser worked.

When testing these changes on an Android with a Chronium browser (which you really must do, sooner or later) there is no way to force a full reload like Ctrl+Shit+R does with the latest Android - so you need to install the Hacker’s Keyboard which allows the Ctrl+Shit+R combination, which works. This is true at the time of this post, but as Google disabled full reload by switching online/offline, then switching desktop on and off - it may only be a matter of time until this trick stops working too.

Note this is only relevant for when you are changing imported .js or .css files, to thoroughly clear the cache.

Thanks for the info, Jawfin