Stylesheets, images, and javascript files don't load

The stylesheet at my site doesn’t load

I am using CakePHP version 2.2.3

The following is in the file: app\View\Elements\header.ctp

<?php echo $this->Html->css(array('myownmealplanner', 'fullcalendar', 'jquery-ui')); ?>

The stylesheet is here: app\webroot\css

When I click on the stylesheet in view source, it doesn’t go to the file. Instead I get the error message: [an error occurred while processing this directive]

What URL is it generating for the stylesheet, and what URL can you actually access it through?

I can’t access the stylesheet at all. When I click on the stylesheet from view source, it goes to but it doesn’t show the stylesheet. It gives me the error: [an error occurred while processing this directive]

I am using PHP version 5.6 gives me 404 - not found.

Wouldn´t it make sense to upgrade your php and rebuild your project with cakephp4?

Rebuilding my site is too much work. I just want to resolve the stylesheet issue easily. The rest of the app works, all I need is for the stylesheets to load.

Is there some URL that you can come up with that does work for that CSS? If so, what is it? If not, then your setup is broken and the problem is nothing to do with the HTML helper.

All links on this page produce “an error occurred while processing this directive]”.
Maybe this could help:

Thanks, dirk.
I uploaded a test.html file to the root and the stylesheet loaded so it seems to be a CakePHP issue.

I changed my file permissions but I still get the error

The error has changed a little bit. It’s now saying: Not Found Error: The requested address ‘/css/test.css?url=css%2Ftest.css’ was not found on this server.

test.css is an empty file that I created because some sources that I googled said that the error could be a result of comments in the file.

I also uploaded test.php to check if php was working and it worked. It loaded the stylesheet.

I previously wasn’t getting any errors so I didn’t report on that but now I’m getting an error in my error_log file. The error is: [11-Mar-2021 20:24:21 UTC] PHP Fatal error: Call to undefined method mysqli::getSchemaName() in /home/sg79q2bkshgg/public_html/ on line 3168

I am consulting with Go Daddy now to make sure my database is configured correctly.

Go Daddy couldn’t help me.
I introduced errors into my app/Config/database.php file to look at the error message but there was no error message. I think the database config is wrong but I don’t see how to check it.

What maybe could help…
Please take a look in your config/database.php.
what is the value of “datasource” ? is it “Database/Mysql” or “Database/Mysqli” ?

It’s ‘datasource’ => ‘Database/Mysqli’,

what happens if you change it to “Database/Mysql” ?
Do you still get the Error

undefined method mysqli


I changed it and I still get the error: [12-Mar-2021 00:55:05 UTC] PHP Fatal error: Call to undefined method mysqli::getSchemaName() in /home/sg79q2bkshgg/public_html/ on line 3168