Unable to follow Blog tutorial

Hi, I tried to follow every single line at the Blog Tutorial. After I created Article Views and try to as what it said to go to the dedicated link to have a look. So far it just keep saying “Unable to emit response; headers already sent”

I had tried to re-download and reinstall the entire package, and it still the same. It keep saying the 2 files have error

  1. vendor/cakephp/cakephp/src/Http/Server.php -> line 107
  2. webroot/index.php -> line 37

I know both files shouldn’t be touched, so I do have question if is my installation failed or both file did have some error? thanks

Does it work properly right after you install CakePHP, without implementing anything from the tutorial? Normally, you should see a CakePHP landing page when you visit the url of your local installation.

If yes, it’s probably some kind of mistake, perhaps empty lines after a closing php tag somewhere.
You could try to add the tutorial code in small increments and should be able to see at what point the error starts to occur.

If no, then it’s likely that your server isn’t correctly configured or the php version is too old.

You can try to clone and install the finished tutorial to check if there is something wrong with you stack setup, or if you missed something in the tutorial