PHP Fatal error: Uncaught exception 'CacheException'


#1

Help:
PHP Fatal error: Uncaught exception ‘CacheException’ with message ‘Cache engine “default” is not properly configured. Ensure required extensions are installed, and credentials/permissions are correct’ in /var/www/html/top/lib/Cake/Cache/Cache.php:186\nStack trace:\n#0 /var/www/html/top/lib/Cake/Cache/Cache.php(151): Cache::_buildEngine(‘default’)\n#1 /var/www/html/top/app/Config/core.php(351): Cache::config(‘default’, Array)\n#2 /var/www/html/top/lib/Cake/Core/Configure.php(72): include(’/var/www/html/t…’)\n#3 /var/www/html/top/lib/Cake/bootstrap.php(431): Configure::bootstrap(true)\n#4 /var/www/html/top/app/webroot/index.php(90): include(’/var/www/html/t…’)\n#5 {main}\n thrown in /var/www/html/top/lib/Cake/Cache/Cache.php on line 186

I can not solve!


#2

set the permission of your project folder,
if you are using ubuntu then to go project folder and run the command “chmod 777 -R ProjectName”


#3

Hello, I have already performed this procedure and deactivated SElinux. However, the problem remains. I use Ubuntu 16.04


#4

This is not secure. You’re allowing anyone read, write and execute permissions to your entire project folder, which is superbly dangerous.


#5

You are right that’s why only tmp & logs folder we have to give the 777 permission. This will solve the problem i think so. :slight_smile:


#6

I would even say that you only need 775 on your tmp and logs folders, as you’ll never need to execute stuff in there.


#7

The error persists, I tried to change the permissions and I did not succeed. I use the older version of the cake. Can the problem be on the server?


#8

The error persists, I tried to change the permissions and I did not succeed. I use the older version of the cake. Can the problem be on the server?


#9

Hi @rpb did you find a solution to your problem? I am having the same issue, i have tried changing permissions, owners checked folders but cannot get this error to go away.


#10

Hi my friend, I don’t found a solution the problem. I need help too.


#11

Hi @rpb i had to disable SELINUX and that fixed my problem and i don’t get the error anymore. The link below describes how to disable SELINUX
https://www.centos.org/docs/5/html/5.1/Deployment_Guide/sec-sel-enable-disable.html
I hope this solves your problem too.


#12

Hi! My problem persists. I do not know to do. Could somebody help me?


#13

Hi can you please tell me how to set permissions in. Windows for this error