Minimum CakePHP version for PHP 7.3/7.4?

I’m currently on CakePHP 3.5
My ISP is forcing us off PHP 7.2 onto either 7.3 or 7.4
There are some errors from the Cake core code in 7.3, mostly related to compact(), but I think there are others as well. I’ve seen references to these errors, but I can’t find a definitive version of Cake to target.

What is the minimum CakePHP version needed for PHP 7.3 or PHP 7.4?

I found this:

CakePHP 3 is a web development framework running on PHP 7.4 (min. PHP 5.6). Read CakePHP at a Glance to get an introduction to the fundamentals of CakePHP 3.


As i understand it, your Version should run with PHP7.4

I wish!! CakePHP 3 is a major version, and has had a long lifetime, and is up to version 3.9. PHP is also climbing the ladder, and each minor version adds breaking changes, which have broken CakePHP. Those changes are always addressed in the next minor version. So there is a correlation between each PHP release and the minimum CakePHP (minor) version number which is needed.

For instance, I was at CakePHP 3.3 when we upgraded to PHP 7. I needed to get to CakePHP 3.5 in order to run. I’m now at CakePHP 3.5 (the last version before the big middleware changes I think) and PHP 7.2. I need to get to at least 7.3 (which is where the breaking changes are) and preferably 7.4

The problem is that you also have to deal with all the other changes within the CakePHP codebase, and the recommendation is to upgrade CakePHP versions one-at-a-time. If you look at the upgrade notes in the Cake documentation, you can see how extensive each change is (often a lot). Although there are often no breaking API changes, there are plenty of behavior changes. So right now I want to target the lowest version which will let me run.