CakePhp is not install on the ubuntu xampp


#1

hello sir
I have a problem on installation of cakephp on ubuntu 16.04
i followed all the instruction given on the website but still it is giving me error Created project in my_app_name
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- cakephp/cakephp 3.3.6 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.5 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.4 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.3 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.2 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.1 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.0-beta3 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.0-beta2 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.0-beta requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.0-RC1 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.3.0 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- Installation request for cakephp/cakephp 3.3.* -> satisfiable by cakephp/cakephp[3.3.0, 3.3.0-RC1, 3.3.0-beta, 3.3.0-beta2, 3.3.0-beta3, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6].

To enable extensions, verify that they are enabled in those .ini files:
- /etc/php/7.0/cli/php.ini
- /etc/php/7.0/cli/conf.d/10-opcache.ini
- /etc/php/7.0/cli/conf.d/10-pdo.ini
- /etc/php/7.0/cli/conf.d/20-calendar.ini
- /etc/php/7.0/cli/conf.d/20-ctype.ini
- /etc/php/7.0/cli/conf.d/20-exif.ini
- /etc/php/7.0/cli/conf.d/20-fileinfo.ini
- /etc/php/7.0/cli/conf.d/20-ftp.ini
- /etc/php/7.0/cli/conf.d/20-gettext.ini
- /etc/php/7.0/cli/conf.d/20-iconv.ini
- /etc/php/7.0/cli/conf.d/20-json.ini
- /etc/php/7.0/cli/conf.d/20-mbstring.ini
- /etc/php/7.0/cli/conf.d/20-phar.ini
- /etc/php/7.0/cli/conf.d/20-posix.ini
- /etc/php/7.0/cli/conf.d/20-readline.ini
- /etc/php/7.0/cli/conf.d/20-shmop.ini
- /etc/php/7.0/cli/conf.d/20-sockets.ini
- /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
- /etc/php/7.0/cli/conf.d/20-sysvsem.ini
- /etc/php/7.0/cli/conf.d/20-sysvshm.ini
- /etc/php/7.0/cli/conf.d/20-tokenizer.ini
i have already remove comment in php.ini extenstion=php_inl,dll
but still giving me errors
please help me and give me steps
thank you


#2

CakePHP requires the PHP intl extension to be installed (As per http://book.cakephp.org/3.0/en/installation.html and the error message that you were given). To install in ubuntu, you need to simply run, apt-get install php7.0-intl


#3

thank you so much sir
it is working actually mbstring was missing after installation of mbstring it is working and once again thank you sir


#4

@dakota can you help me too, to install intl extension on mac os mojave’s own php 7.1.19 without brew and macports (I want to continue with mac’s own php). I could install pecl but it needs icu (libicu) now. I stopped there :slight_smile:


#5

I just use homebrew :slight_smile:


#6

Hi @dakota I found my way and explained here How to install PHP Intl on macOS Mojave . Thanks and best regards.