Cakephp 5 zend.assertion = 1 error

Hi!!! everyone, I need help to resolve my issue, development server throw zend.assert = 1.
in apache2 i have already set zend.assertion = 1 but still it ask for set zend.asseertion = 1.

Screenshot from 2024-03-11 12-01-11

development server running and you can see there

browser also have throw that exception

Is that definitely the php.ini file that is used by your web server? There’s often multiple ini files for different purposes.

If it’s a recent change that you made, did you restart your web server after making that change?

thanks @Zuluru and yes its php.ini file & already restart server twice of time but that warning still has there. if i run cakephp built in server bin/cake server http://localhost:8765 then got that error but if i open my project without running cakephp server then everything fine and there would be no any error show:- http://localhost/cakeproject

I have never really used the built in server, but I suspect it might use a different ini file than Apache? Try a phpinfo() in a page loaded with both options and see what it has to say about what ini files are loaded.

1 Like

thanks @Zuluru you solved my problem, yes apache2 using another configuration file so i just changed and assertions value and now all fine. thanks @Zuluru