Upload cakephp3 project to online server

Hello
i have installed a project in cakephp3.8 in localhost with oven using wamp and my project works well. when i have uploaded my project to a subdomain on a server, i have this error:

Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@collector.oiecameroun.org to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
my database is well configured. i don’t what another configuration to do to resolve this problem. thks

Depends on the server. Usually you forgot to upload the invisible .htaccess somewhere or tinkered with the .htaccess or if you have global apache/nginx config … well something is not right with that config.

Put only a simple test.php with an echo in the subfolder and check if you can access that.

i have try to put file oven.php in my subfolder to install cakephp3 online and it was a success but after i have the save problem to display my project. there is my .htaccess root file content:

# Uncomment the following to prevent the httpoxy vulnerability
# See: https://httpoxy.org/
#<IfModule mod_headers.c>
#    RequestHeader unset Proxy
#</IfModule>

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule    ^(\.well-known/.*)$ $1 [L]
    RewriteRule    ^$    webroot/    [L]
    RewriteRule    (.*) webroot/$1    [L]
</IfModule>

and there is my .htaccess webroot file content:

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

This isn’t app level error. Your server configuration is mis-matching.
What middleware are you using?

Just went on the URL : http://collector.oiecameroun.org

Now it is app level configuration error.

So you solved the server error by yourself, well done!

Now… It redirected me to the login page, which tells me to replace home.ctp because it is default cakephp. Have you uploaded your source code?

ok my server is on LWS cpanel

which kind of server(with parameters) do i use to upload my cakephp3 project ?

which kind of server(with parameters) do i use to upload my cakephp3 project ?

Usually uploading a project to the server should just™ work. There’s nothing special about it. Maybe try uploading a new and empty Cake 3 skeleton app without any custom code that works locally and see if that gets served.

If you have an administration panel I would look for webserver (error) logs, that should give you a hint.

ok i will check it. thks

Turn on your DEBUG mode (public_html/config/app.php file)

‘debug’ => filter_var(env(‘DEBUG’, true), FILTER_VALIDATE_BOOLEAN),

Now if you run your site error cause will showed. If still showing Internal error.

Delete all previous log files from server logs folder (public_html/logs).
Then run your web site. Once your site loaded and you get that internal error.

goto public_html/logs logs folder and check your error.log file. You can get each error details from there.

ok thanks you Debendra. i will apply it