[SOLVED] Debugkit not showing


  • nginx/1.13.12

  • fpm

  • php7.1

  • cakephp 3.6

  • debugkit 3.0 (EDIT: is 3.15 actually)

  • home.ctp reports “DebugKit is loaded.”

  • sqlite3 extension loaded and tested

  • bin/cake plugin assets symlink - symlink created

  • app.php ‘debug’ => TRUE

  • bootstrap.php Plugin::load(‘DebugKit’, [‘bootstrap’ => true]);

still NO debugkit bar or debugkit code in sourcefile

the only error I see is

“Your Application class does not have a bootstrap() method. Please add one.”

when I run

“bin/cake plugin load DebugKit”

Out of disperation I have added a bootstrap() method to src/Application.php but this returns a 500/An Internal Server Error Occurred

I’m out of ideas, google querys and debug paths.

Please help?

Thank you.

How did you install cake and debugkit?

Both via composer


to expand on the answer

composer.phar create-project --prefer-dist cakephp/app project
composer.phar require --dev cakephp/debug_kit “~3.0”

Fixed my issue with some digging.

What I found:

  1. if you use sqlite3 and not pdo_sqlite - DebugKit will not work (see debug_kit/config/bootstrap.php line 32)

  2. if your TLDis not [“localhost”, “dev”, “invalid”, “test”, “example”, “local”] - DebugKit will not work (see debug_kit/src/ToolbarService.php line 133)

I have reported both as issues on git (610 and 611)

DebugKit 3.0 isn’t compatible with CakePHP 3.6, you’ll need to make sure you’ve installed at least 3.15

1 Like

It is 3.15.

My mistake while writing the first post.