DebugKit missing after deploying to Heroku

Hey!
I want to play around with my stuff on a live server but I always get a Missing Plugin Exception:

I already tried a lot of stuff including this:
http://stackoverflow.com/questions/31417334/cakephp-3-error-the-application-is-trying-to-load-a-file-from-the-debugkit-plug

but it’s still there. Anybody knows where it might come from. I would turn off the debug mode completely (then it works), but then I am obviously lost if some error comes up.

The application build there is pretty fresh and I am currently using the latest version of cake and of composer.

Thanks in Advance!

The debugkit supported with sqlite. Do you have the server setup with sqlite?

1 Like

Thanks for your hint!

This must be the problem :smiley:

Heroku in its documentation doesn’t approve of SQLite. So I wanted to go with their advice about PostgreSQL instead. Is there any good way to make it flawlessly?

Heroku offers a good documentation on this but I am not sure how to apply it to CakePHP. Maybe somebody knows a tutorial or has set it up before and can give a little guide on that?

OK, I’ve tried it for a week now, but I only make it worse:

Luckily I had a recent version on my time machine :clap:

Who can and want mentor me through this? I offer a lot of great beer from Berlin or whatever you like. Or somebody may make me an offer? (like money wise)

I want to get it up and running soon, but I feel like I won’t get it done in near future without further help.

IIRC this one is related to some change to debugKit, so try to delete ‘tmp/debug_kit.sqlite’

no, this alone, unfortunately, doesn’t solve the problem

hm start by trying to disable debug in ‘config/app.php’ all together if that helps its probably something related to sqlLite - permissions or some other thing but at least it would let focus your attention

yeah with debug mode turned off it works, I think I mentioned that in the OP.

Do you think I should then focus on switching to posgresql and the problem will be solved?

yeah with debug mode turned off it works, I think I mentioned that in the OP.

oh! sorry missed that

you can try, you can define any database as source for debugKit - i dont know if you would have to define some schma for it as i personaly havent done it, https://github.com/cakephp/debug_kit/blob/master/config/bootstrap.php

Thank you for your help, I will have a look into that. Maybe something gets clearer.

You seem to have had a smooth setup of CakePHP on Heroku?