Problems with installation of Cakephp4

I followed the instructions for downloading and installation of cakephp4, however, my server is not wanted to connect to the index page. I am using the development server method where you use bin server -H some IP address, -p port address and I get HTTP 500 error. can someone please walk me through some troubleshooting? Here is the link to the installation Guide I am using:

You tried the default? http://localhost:8765 You have installed php. You will have a better experience with a bitnami wamp stack or xampp. I prefer bitnami.

I get the same error with Xampp as well

I’m very familiar with that screen. It’s when i forget to start the built-in server …

ah, so there is a way to start it, the installation guide does not mention this, so how do you start the built in cake server?

yes, I did that, that is how I got to what you see now

Did you read the specifics in the section that I linked directly to? Because they literally are the directions for starting the built-in server.

You’re on windows and opened the command prompt? Then go to the bin-directory of your cakephp-project and type ‘cake server’.

What’s the response?

Nothing…it just blinks to another line

What about bin\cake server from the main cake directory, instead of from inside bin?

And just ‘cake --help’ in the bin?

you saying just do cake server without the bin part correct?

i just tried bin\cake sever…it just blinked to new line

yeah I tried it both ways and by the link that you sent…and still get the http 500 error…strange

now it says local host refused to connect

bin\cake should give a version number, and a list of possible commands. bin\cake server should give the same but say something like “built-in server is running” instead of the list of commands. Do either of those things work as expected for you? Completely separate from whether anything works in your browser.

no, not seeing any of that…it just drags for a minute and than and goes to a new line…maybe I need to redownload cakephp again…let me try that.