Cant install cakephp 4

I have wamp64 /win10 and downloaded cakephp 3.9.* and it worked fine. I have php 7.4

I have composer and ran commands from www folder

I tried to download cakephp 4 and kept getting this error in my console

could not find package cakephp/app with version 4. in a version installable with your php version, php extension and composer version*

All these commands got the same error
composer self-update && composer create-project --prefer-dist cakephp/app:4.0.* crm4
composer create-project --prefer-dist “cakephp/app:^4.0” crm4

i cant install cakephp 4

I just installed 4.2.0-RC1 no problems. Make sure your composer.json is correct.

A version of app has to work with a version of framework (vendor stuff).

The installation now cuts out towards the end with this error

composer create-project --prefer-dist cakephp/app:~4.0 my_app_name

handing the post create project cmd event terminated with an exception and some Symfony runtime exception when you get to the set folder permission y/n 

the json file is

    "name": "cakephp/app",
    "description": "CakePHP skeleton app",
    "homepage": "",
    "type": "project",
    "license": "MIT",
    "require": {
        "php": ">=7.2",
        "cakephp/cakephp": "~4.2.0",
        "cakephp/migrations": "^3.0",
        "cakephp/plugin-installer": "^1.3",
        "mobiledetect/mobiledetectlib": "^2.8"
    "require-dev": {
        "cakephp/bake": "^2.3",
        "cakephp/cakephp-codesniffer": "~4.2.0",
        "cakephp/debug_kit": "^4.4",
        "josegonzalez/dotenv": "^3.2",
        "phpunit/phpunit": "~8.5.0 || ^9.3",
        "psy/psysh": "@stable"
    "suggest": {
        "markstory/asset_compress": "An asset compression plugin which provides file concatenation and a flexible filter system for preprocessing and minification.",
        "dereuromark/cakephp-ide-helper": "After baking your code, this keeps your annotations in sync with the code evolving from there on for maximum IDE and PHPStan/Psalm compatibility.",
        "phpstan/phpstan": "PHPStan focuses on finding errors in your code without actually running it. It catches whole classes of bugs even before you write tests for the code."
    "autoload": {
        "psr-4": {
            "App\\": "src/"
    "autoload-dev": {
        "psr-4": {
            "App\\Test\\": "tests/",
            "Cake\\Test\\": "vendor/cakephp/cakephp/tests/"
    "scripts": {
        "post-install-cmd": "App\\Console\\Installer::postInstall",
        "post-create-project-cmd": "App\\Console\\Installer::postInstall",
        "check": [
        "cs-check": "phpcs --colors -p  src/ tests/",
        "cs-fix": "phpcbf --colors -p src/ tests/",
        "stan": "phpstan analyse",
        "test": "phpunit --colors=always"
    "prefer-stable": true,
    "config": {
        "sort-packages": true

If you continue having trouble, go here:

Download 4.2.1

Extract in correct folder

run composer install

manually make a logs folder and give permissions.

That’s how I normally install anyway.

I just tested by doing a new install, all went good.

Or in above line:

composer create-project --prefer-dist cakephp/app:~4.0 my_app_name

Try changing to

composer create-project --prefer-dist cakephp/app:~4.2 my_app_name

I did not try that yet.

hey @jagguy
maybe you entering the wrong command for installing a cakephp because here is the syntax of your command:
composer self-update && composer create-project --prefer-dist cakephp/app:4.0. crm4
composer create-project --prefer-dist “cakephp/app:^4.0” crm4
and here is the right syntax from the official site that is different from your commands :
composer create-project --prefer-dist cakephp/app:~4.0 my_app_name

i just needed to create the install folder first, simple fix