Cakephp on ubuntu error

I just install ubuntu and when i run my project i’m getting an error .

**Warning** : require(/opt/lampp/htdocs/starcon/vendor/autoload.php): failed to open stream: No such file or directory in  **/opt/lampp/htdocs/starcon/config/bootstrap.php**  on line  **38**

**Fatal error** : require(): Failed opening required '/opt/lampp/htdocs/starcon/vendor/autoload.php' (include_path='.:/opt/lampp/lib/php') in  **/opt/lampp/htdocs/starcon/config/bootstrap.php**  on line  **38**

After installing ubuntu, what did you do to put your project on it? Did it involve composer at all? It looks like the autoload information wasn’t generated.

did you create your project using composer create-project?

have u tried composer install or update in this new server? looks like not all required files were there

I actually made a guide, mostly for my own reference, on how to install CakePHP on ubuntu from start to finish using apache. If you have any interest, you can look at that here.