Upgrading to 4.0.0-beta3 from release 3.8.x

Has anyone manged to upgrade a 3.8.x application to 4.0.0-beta3 using the migration guide in the release 4.0 docs.
I get the following errors on windows10 running composer from the GIT bash shell.


$ composer require --update-with-dependencies “cakephp/cakephp: 4.0.0-beta3”
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- cakephp/bake 1.11.2 requires cakephp/cakephp ^3.8.0 -> satisfiable by cakephp/cakephp[3.8.0, 3.8.0-RC1, 3.8.0-RC2, 3.8.0-RC3, 3.8.0-beta1, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5] but these conflict with your requirements or minimum-stability.
- cakephp/bake 1.11.2 requires cakephp/cakephp ^3.8.0 -> satisfiable by cakephp/cakephp[3.8.0, 3.8.0-RC1, 3.8.0-RC2, 3.8.0-RC3, 3.8.0-beta1, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5] but these conflict with your requirements or minimum-stability.
- cakephp/bake 1.11.2 requires cakephp/cakephp ^3.8.0 -> satisfiable by cakephp/cakephp[3.8.0, 3.8.0-RC1, 3.8.0-RC2, 3.8.0-RC3, 3.8.0-beta1, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5] but these conflict with your requirements or minimum-stability.
- Installation request for cakephp/bake (locked at 1.11.2, required as ^1.9) -> satisfiable by cakephp/bake[1.11.2].

Installation failed, reverting ./composer.json to its original content.

Seems I have the wrong bake version installed. But when I try to install bake 2.0 I get:

$ composer require --dev cakephp/bake:2.0.*
[InvalidArgumentException]
Could not find package cakephp/bake in a version matching 2.0.*

require [–dev] [–prefer-source] [–prefer-dist] [–no-progress] [–no-suggest] [–no-update] [–no-scripts] [–update-no-dev] [–update-with-dependencies] [–update-with-all-dependencies] [–ignore-platform-reqs] [–prefer-stable] [–prefer-lowest] [–sort-packages] [-o|–optimize-autoloader] [-a|–classmap-authoritative] [–apcu-autoloader] [–] []…

How has your upgrade gone?

For me it was easier to just do a new fresh install, then migrate code over. It just takes a little time.