Can't start CakePHP

I’m using Apache2 and Firefox 53.0.2 on Mac OS 10.11.3.
I installed composer, and then create my CakePHP project using the following command :

php composer.phar create-project --prefer-dist cakephp/app patientcare

All the directory hierarchy gets duly created.
But when I try to access index.php from my Firefox browser, I only see a completely blank page.
In the error log, I read :

[:error] [pid 48494] [client 127.0.0.1:57358]
PHP Parse error: parse error, expecting '&'' or“variable (T_VARIABLE)”'
in patientcare/vendor/cakephp/cakephp/src/I18n/functions.php on line 26

So I obediently looked at line 26 of vendor/cakephp/cakephp/src/I18n/functions.php ;
it is the first line of this paragraph :

function __($singular, …$args)
{
if (!$singular) {
return null;
}
if (isset($args[0]) && is_array($args[0])) {
$args = $args[0];
}

    return I18n::translator()->translate($singular, $args);
}

I don’t really understand the error message, so I’m stuck at this point.
Any help appreciated.

What exact versions of PHP and CakePHP are you using?

Here is the output of php -v :

PHP 5.6.7 (cli) (built: Apr  9 2015 19:32:03) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
    with Xdebug v2.2.5-komodo, Copyright (c) 2002-2014, by Derick Rethans

And it’s CakePHP 3.0 I’m using.

I just found that bin/cake server -p 8765and typing http://localhost:8765 in my browser works, but I’m still curious to know why the first way doesn’t work

Even when 5.6.7 should be sufficient - Is there a special reason for combining a rather old PHP Version with CakePHP 3?

Normally this error indicates an outdated PHP Version - Are you sure that your webserver uses the same PHP Version like shown in CLI?
What does echo phpversion(); instead of a CLI command print out?

This definately sounds like an outdated version of the the webserver php (Which is different than the one run in the shell)

i use mac os version 10.15.5
php version:
PHP 7.1.4 (cli) (built: May 10 2017 16:03:28) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright © 1998-2017 Zend Technologies
i use composer: composer create-project --prefer-dist cakephp/app my_app_name
install normal but to step Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- cakephp/cakephp 3.4.7 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.4.6 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.4.5 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.4.4 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.4.3 requires ext-intl * -> the requested PHP extension intl is missing from your system.
- cakephp/cakephp 3.4.2 requires lib-icu >=4.8 -> the requested linked library icu has the wrong version installed or is missing from your system, make sure to have the extension providing it.
- cakephp/cakephp 3.4.1 requires lib-icu >=4.8 -> the requested linked library icu has the wrong version installed or is missing from your system, make sure to have the extension providing it.
- cakephp/cakephp 3.4.0 requires lib-icu >=4.8 -> the requested linked library icu has the wrong version installed or is missing from your system, make sure to have the extension providing it.
- Installation request for cakephp/cakephp 3.4.* -> satisfiable by cakephp/cakephp[3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7].

To enable extensions, verify that they are enabled in your .ini files:
- /Applications/XAMPP/xamppfiles/etc/php.ini
You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

could you help me.

Fixed now since I succeded in updating PHP. Thanks to all the people who helped.