CakePHP 4: phpUnit use "default" db config instead of "test" @scrutinizer

Huston we have problem!

We running tests locally without any problem, cake use our test and test_fixtures configuration with db username and password. But when we push code, then use online scrutinizer tool ( to test our app. And there is now problem, while there test now use default db config instead of test??? Old CakePHP 3 @scrutinizer not have this problem.

We add in fixture public $connection = 'test_fixtures'; but without success.

PHPUnit 8.5.2 by Sebastian Bergmann and contributors.

IIIIIIIIIIIIIIII..Exception: SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: YES)
In [/home/scrutinizer/build/vendor/cakephp/cakephp/src/Database/Driver.php, line 102]

How to fix?

OK, I found solution, setting connection when import model in fixtures.

$connection = 'test';
public $import = ['model' => 'Users', 'connection' => 'test'];

did you rename phpunit.xml.dist to phpunit.xml ?
from what i understand phpunit searches for phpunit.xml by default and its where FixtureManager handles aliasing default connection to test

Nope! We did not rename phpunit.xml.dist.