# Upgrading from 4.2 to 4.3 on PHP 8.0

**URL:** <https://discourse.cakephp.org/t/upgrading-from-4-2-to-4-3-on-php-8-0/11116>\
**Category:** Need Help\
**Created:** [April 4, 2023, 2:35am UTC](https://discourse.cakephp.org/t/upgrading-from-4-2-to-4-3-on-php-8-0/11116 "2023-04-04T02:35:21Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![DaveM](https://avatars.discourse-cdn.com/v4/letter/d/67e7ee/32.png) [@DaveM](https://discourse.cakephp.org/u/DaveM)\
**Post date:** [April 4, 2023, 2:35am UTC](https://discourse.cakephp.org/t/upgrading-from-4-2-to-4-3-on-php-8-0/11116/1 "2023-04-04T02:35:21Z")

</div>

I am running into problems migrating. I am on PHP 8.2 and when I use the composer update command I get:  
Problem 1  
- laminas/laminas-httphandlerrunner[1.1.0, …, 1.2.0] require php ^7.1 → your php version (8.2.0) does not satisfy that requirement.  
- laminas/laminas-httphandlerrunner[1.3.0, …, 1.4.0] require php ^7.3 || ~8.0.0 → your php version (8.2.0) does not satisfy that requirement.  
- laminas/laminas-httphandlerrunner 1.5.0 requires php ^7.3 || ~8.0.0 || ~8.1.0 → your php version (8.2.0) does not satisfy that requirement.  
- cakephp/cakephp 4.3.0 requires laminas/laminas-httphandlerrunner ^1.1 → satisfiable by laminas/laminas-httphandlerrunner[1.1.0, …, 1.5.0].  
- Root composer.json requires cakephp/cakephp 4.3 → satisfiable by cakephp/cakephp[4.3.0].

I try to do the update with all dependencies but still have a similar problem.

Thanks for any help you can offer.  
Dave.
