# Update to 4.3.4 problem with composer

**URL:** <https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100>\
**Category:** Need Help\
**Created:** [January 19, 2022, 8:22pm UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100 "2022-01-19T20:22:08Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![shadowx.jb](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@shadowx.jb](https://discourse.cakephp.org/u/shadowx.jb)\
**Post date:** [January 19, 2022, 8:22pm UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100/1 "2022-01-19T20:22:08Z")

</div>

I updated version to 4.3.4. and uploaded to server and then error:

```auto
 Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.0.2". You are running 8.0.1. in /www/vendor/composer/platform_check.php on line 24

```

On localhost its ok… please help.

---

<div class="post-metadata">

**Author:** ![Zuluru](https://yyz1.discourse-cdn.com/flex029/user_avatar/discourse.cakephp.org/zuluru/32/1230_2.png) [@Zuluru](https://discourse.cakephp.org/u/Zuluru)\
**Post date:** [January 19, 2022, 8:45pm UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100/2 "2022-01-19T20:45:51Z")

</div>

The error message seems pretty clear?

---

<div class="post-metadata">

**Author:** ![shadowx.jb](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@shadowx.jb](https://discourse.cakephp.org/u/shadowx.jb)\
**Post date:** [January 19, 2022, 9:04pm UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100/3 "2022-01-19T21:04:43Z")

</div>

I understand, but I don’t know how to solve …

---

<div class="post-metadata">

**Author:** ![KevinPfeifer](https://yyz1.discourse-cdn.com/flex029/user_avatar/discourse.cakephp.org/kevinpfeifer/32/3365_2.png) [@KevinPfeifer](https://discourse.cakephp.org/u/KevinPfeifer)\
**Post date:** [January 19, 2022, 9:19pm UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100/4 "2022-01-19T21:19:53Z")

</div>

Well, either update you used PHP Version to 8.0.2 or higher

or

find the package which requires PHP 8.0.2 via composer and up/downgrade it

```auto
composer why php

```

---

<div class="post-metadata">

**Author:** ![shadowx.jb](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@shadowx.jb](https://discourse.cakephp.org/u/shadowx.jb)\
**Post date:** [January 19, 2022, 9:44pm UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100/5 "2022-01-19T21:44:08Z")

</div>

Thank You! Its works

---

<div class="post-metadata">

**Author:** ![Zuluru](https://yyz1.discourse-cdn.com/flex029/user_avatar/discourse.cakephp.org/zuluru/32/1230_2.png) [@Zuluru](https://discourse.cakephp.org/u/Zuluru)\
**Post date:** [January 19, 2022, 11:13pm UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100/6 "2022-01-19T23:13:00Z")

</div>

Good example of why it’s important to run _exactly_ the same version of _everything_ on your dev and production systems, if at all possible.

---

<div class="post-metadata">

**Author:** ![shadowx.jb](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@shadowx.jb](https://discourse.cakephp.org/u/shadowx.jb)\
**Post date:** [January 20, 2022, 7:33am UTC](https://discourse.cakephp.org/t/update-to-4-3-4-problem-with-composer/10100/7 "2022-01-20T07:33:10Z")

</div>

Add this to composer.json:

```auto
    "config": {
        "platform": {
            "php": "8.0.1"
        }
    },

```
