MooSocial based on CakePHP

Hi all,
a client of mine has an older version of MooSocial, and as you might or might not know, it is based on CakePHP. And since it is an older version, and he is not interested in upgrading atm, I come to you…

It has a built in api, and the core is set up and I have checked it. I have even tried using postman to see if the api launches, and yes it does.

But when I reengineer an moo social based app and add the url to the site, i only get this error here when trying to sign in or sign up: Error when load config from server. I have been at it for days, but I am not usually developing in php and not used cakephp before, so I can’t find the problem. It is not an very old version of MooSocial, so it is not a version problem…

Thanks for any help on this topic.

You’ll probably need to provide more context around the error or possibly a stack trace before people who aren’t familiar with MooSocial could help you.

Sorry for that. This app that I reverse Engineered I tested reverse engineering it to several other moo social websites, and all but this website and another one that is on the latest version of moosocial works.

There is no other error in the app. It loads up on the start screen, but when I try going to registration the error appear.

The website that it is hooked up to is: http://groupify.net

Here is the app directory and buildup:

the app.json and app config.json
looks like this:
{
“general”: {
“initialUrl”: “http://127.0.0.1/moolab/2.2.2”,
“enableGCM”: true,
“notificationTime” : 3000,
“googleAppSenderId”: “”,
“googleApiKey” : “”,
“enablePostDelete” : false,
“apiKey” : “3242343”
},
“list_urls”:{
“all_notification”:"/notifications/ajax_show/home",
“home_everyone”:"/activities/ajax_browse/everyone",
“home_friend”:"/activities/ajax_browse/friends",
“term_service” : “/pages/term-of-service”,
“link_create_account” : “/users/avatar”
}
,
“menus”: {
“pages”:[
{
“url”: “/pages/about-us”,
“label”: “About Us”,
“key”: “pages_about_us”
},
{
“url”: “/pages/term-of-service”,
“label”: “Term of Service”,
“key”: “pages_term_service”
},
{
“url”: “/pages/privacy-policy”,
“label”: “Privacy Policy”,
“key”: “pages_privacy_policy”
},
{
“url”: “/home/contact”,
“label”: “Contact Us”,
“key”: “pages_contact_us”
}
],
“account”:[
{
“url”: “/users/profile”,
“label”: “Profile Information”,
“key”: “account_profile”
},
{
“url”: “/users/avatar”,
“label”: “Change Profile Picture”,
“key”: “account_picture”
},
{
“url”: “/users/password”,
“label”: “Change Password”,
“key”: “account_password”
},
{
“url”: “/conversations/ajax_browse”,
“label”: “Message”,
“key”: “message_manage”
},
{
“url”: “/friends/ajax_invite”,
“label”: “Invite Friends”,
“key”: “account_invite”
}
],
“items”: [
{
“url”: “/activities/ajax_browse/everyone”,
“label”: “Home”,
“icon”:“ic_home”,
“key”: “home”,
“subLinks”: []
},
{
“url”: “/users”,
“label”: “People”,
“icon”:“ic_member”,
“key”: “users”,
“subLinks”: [
{
“url”: “/users”,
“label”: “Everyone”
},
{
“url”: “/users/ajax_browse/friends”,
“label”: “My Friends”
}
]
},
{
“url”: “/blogs”,
“label”: “Blogs”,
“icon”:“ic_blog”,
“key”: “blogs”,
“subLinks”: [
{
“url”: “/blogs”,
“label”: “All Entries”
},
{
“url”: “/blogs/browse/my”,
“label”: “My Entries”
},
{
“url”: “/blogs/browse/friends”,
“label”: “Friends’ Entries”
}
]
},
{
“url”: “/photos”,
“label”: “Photos”,
“icon”:“ic_photo”,
“key”: “photos_albums”,
“subLinks”: [
{
“url”: “/photos”,
“label”: “All Photos”
},
{
“url”: “/albums/browse/my”,
“label”: “My Photos”
},
{
“url”: “/albums/browse/friends”,
“label”: “Friends’ Photos”
}
]
},
{
“url”: “/videos”,
“label”: “Videos”,
“icon”:“ic_video”,
“key”: “videos”,
“subLinks”: [
{
“url”: “/videos”,
“label”: “All Videos”
},
{
“url”: “/videos/browse/my”,
“label”: “My Videos”
},
{
“url”: “/videos/browse/friends”,
“label”: “Friends’ Videos”
}
]
},
{
“url”: “/topics”,
“label”: “Topics”,
“icon”:“ic_topic”,
“key”: “topics”,
“subLinks”: [
{
“url”: “/topics”,
“label”: “All Topics”
},
{
“url”: “/topics/browse/my”,
“label”: “My Topics”
},
{
“url”: “/topics/browse/friends”,
“label”: “Friends’ Topics”
}
]
},
{
“url”: “/groups”,
“label”: “Groups”,
“icon”:“ic_group”,
“key”: “groups”,
“subLinks”: [
{
“url”: “/groups”,
“label”: “All Groups”
},
{
“url”: “/groups/browse/my”,
“label”: “My Groups”
},
{
“url”: “/groups/browse/friends”,
“label”: “Friends’ Groups”
}
]
},
{
“url”: “/events”,
“label”: “Events”,
“icon”:“ic_event”,
“key”: “events”,
“subLinks”: [
{
“url”: “/events”,
“label”: “All Events”
},
{
“url”: “/events/browse/my”,
“label”: “My Events”
},
{
“url”: “/events/browse/friends”,
“label”: “Friends’ Events”
}
]
}
]
}
}

appconfig.json
{
“general”: {
“initialUrl”: “https://groupify.net”,
“enableGCM”: true,
“notificationTime” : 3000,
“googleAppSenderId”: “”,
“googleApiKey” : “”,
“enablePostDelete” : false,
“apiKey” : “betamoo”,
“defaultLanguage” : “en”
},
“list_urls”:{
“all_notification”:"/notifications/ajax_show/home",
“home_everyone”:"/activities/ajax_browse/everyone",
“home_friend”:"/activities/ajax_browse/friends",
“term_service” : “/pages/terms-of-service”,
“link_create_account” : “/users/avatar”
},
“languages” : [
{
“label”: “English”,
“key”: “en”
},
{
“label”: “Portuguese”,
“key”: “pt”
}
]
}

Hope this helps so you could help me. hehe…

I have been working on this non stop, and I have gotten every setting correct based on the calling of the restAPI. It works everywhere but not in the app… Any Ideas?

I found this address in MooApi.smali http://192.168.168.7/moolab/2.2.2/api/
Could this be something that is destroying the connection ?